`

8596 最长上升子序列

 
阅读更多

8596 最长上升子序列(必做)

时间限制:300MS  内存限制:1000K
提交次数:255 通过次数:118

题型: 编程题   语言: C++;C;VC;JAVA

Description

A numeric sequence of ai is ordered if a1 < a2 < ... < aN. 
Let the subsequence of the given numeric sequence (a1, a2, ..., aN) be any sequence (ai1, ai2, ..., aiK), where 1 <= i1 < i2 < ... < iK <= N. 
For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. 
All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8). 

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence. 




输入格式

There are several test cases. Every test case includes two lines. 
The first line contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, 
separated by spaces. 1 <= N <= 1000 
When N is 0, it indicates test to end. 



输出格式

Output must contain a single integer for every test case ---- the length of the longest ordered subsequence of the given sequence. 



输入样例

7
1 7 3 5 9 4 8
6
1 8 3 6 5 9
5
1 2 3 4 5
0



输出样例

4
4
5

 

#include <iostream>

#include <stdio.h>

using namespace std;

int n;

int a[10000];  //The second line contains the elements of sequence - N integers in the range from 0 to 10000 each,

int f[10000];  // 注意数组大小

int max1=0;

int num=0;

void searchM()

{

 

    for(int i=0;i<n;i++)

    {

        f[0] = 1; max1 = 0;  //初始化

       for(int j=0;j<i;j++)  // 从0到i的前一位

       {

           if(a[i]>a[j])   // 如果比当前位小

           {

               if(max1 < f[j]) // 更新 记录最大长度 注意是J

             max1 = f[j];

           }

       }

       f[i] = max1+1;  //把从第一位到当前位的最大长度+1 (加上自身)

    }

}

 

int main()

{

    //freopen("in.txt","r",stdin);

    cin >>n;

    while(n)

    {

        for(int i=0;i<n;i++)

            cin >>a[i];

        searchM() ;

        int temp=f[0];

        for(int i=1;i<n;i++)

        {

            if(f[i]>temp)

                temp=f[i];

        }

        cout<< temp<<endl;

 

        cin >>n;

    }

 

    return 0;

}

 

分享到:
评论

相关推荐

Global site tag (gtag.js) - Google Analytics